#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([^/]+)/(?!.*(contact|about|subscribe|favorite)).+$"
Local $sString = "mrk/not-that" & @CRLF & _
"dir/" & @CRLF & _
"dir/contact" & @CRLF & _
"dir/about/anything" & @CRLF & _
"dir/subdir" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")