import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^/]+)/(?!.*(contact|about|subscribe|favorite)).+$";
final String string = "mrk/not-that\n"
+ "dir/\n"
+ "dir/contact\n"
+ "dir/about/anything\n"
+ "dir/subdir\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}