re = /^([^\/]+)\/(?!.*(contact|about|subscribe|favorite)).+$/m
str = 'mrk/not-that
dir/
dir/contact
dir/about/anything
dir/subdir
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end