using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^/]+)/(?!.*(contact|about|subscribe|favorite)).+$";
string input = @"mrk/not-that
dir/
dir/contact
dir/about/anything
dir/subdir
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}