$re = '~^([^/]+)/(?!.*(contact|about|subscribe|favorite)).+$~m';
$str = 'mrk/not-that
dir/
dir/contact
dir/about/anything
dir/subdir
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);