#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![0-9]+$)(?=.*[a-zA-Z])[a-zA-Z0-9]+$"
Local $sString = "admin" & @CRLF & _
"l0v3y0oplj" & @CRLF & _
"123admin" & @CRLF & _
"123ADMIN?" & @CRLF & _
"123ADMIN" & @CRLF & _
"am.ouy?" & @CRLF & _
"12345678909776apouatgb" & @CRLF & _
"1ads967bjk" & @CRLF & _
"ADMIN123" & @CRLF & _
"123" & @CRLF & _
",;/.;..,,;.#$¨$#¨%" & @CRLF & _
"!@#$%3333333333333333333332"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")