using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?![0-9]+$)(?=.*[a-zA-Z])[a-zA-Z0-9]+$";
string input = @"admin
l0v3y0oplj
123admin
123ADMIN?
123ADMIN
am.ouy?
12345678909776apouatgb
1ads967bjk
ADMIN123
123
,;/.;..,,;.#$¨$#¨%
!@#$%3333333333333333333332";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}