re = /^(?![0-9]+$)(?=.*[a-zA-Z])[a-zA-Z0-9]+$/m
str = 'admin
l0v3y0oplj
123admin
123ADMIN?
123ADMIN
am.ouy?
12345678909776apouatgb
1ads967bjk
ADMIN123
123
,;/.;..,,;.#$¨$#¨%
!@#$%3333333333333333333332'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end