import re
regex = re.compile(r"^(?![0-9]+$)(?=.*[a-zA-Z])[a-zA-Z0-9]+$", flags=re.MULTILINE)
test_str = ("admin\n"
"l0v3y0oplj\n"
"123admin\n"
"123ADMIN?\n"
"123ADMIN\n"
"am.ouy?\n"
"12345678909776apouatgb\n"
"1ads967bjk\n"
"ADMIN123\n"
"123\n"
",;/.;..,,;.#$¨$#¨%\n"
"!@#$%3333333333333333333332")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")