#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\-(\s*\d+\s*\/\s*\d+\s*\/\s*\d+)(\s*\*\s*\d+)?"
Local $sString = "" & @CRLF & _
"I'm looking for regex to match date type patterns which start with hyphen and possible * + digit that might come after it. I have text input like this:" & @CRLF & _
"" & @CRLF & _
"- 19/03/2081" & @CRLF & _
"- 20 / 02 / 1982" & @CRLF & _
"- 11/3/1950 * 1" & @CRLF & _
"- 21 / 11 / 2120 * 500000" & @CRLF & _
"01 / 09 / 2021" & @CRLF & _
"- 21 / 09 / 2021" & @CRLF & _
"20 / 09 / 2021 * 3" & @CRLF & _
"***12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")