using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\-(\s*\d+\s*\/\s*\d+\s*\/\s*\d+)(\s*\*\s*\d+)?";
string input = @"
I'm looking for regex to match date type patterns which start with hyphen and possible * + digit that might come after it. I have text input like this:
- 19/03/2081
- 20 / 02 / 1982
- 11/3/1950 * 1
- 21 / 11 / 2120 * 500000
01 / 09 / 2021
- 21 / 09 / 2021
20 / 09 / 2021 * 3
***12";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}