package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\-(\s*\d+\s*\/\s*\d+\s*\/\s*\d+)(\s*\*\s*\d+)?`)
var str = `
I'm looking for regex to match date type patterns which start with hyphen and possible * + digit that might come after it. I have text input like this:
- 19/03/2081
- 20 / 02 / 1982
- 11/3/1950 * 1
- 21 / 11 / 2120 * 500000
01 / 09 / 2021
- 21 / 09 / 2021
20 / 09 / 2021 * 3
***12`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}