$re = '/\-(\s*\d+\s*\/\s*\d+\s*\/\s*\d+)(\s*\*\s*\d+)?/m';
$str = '
I\'m looking for regex to match date type patterns which start with hyphen and possible * + digit that might come after it. I have text input like this:
- 19/03/2081
- 20 / 02 / 1982
- 11/3/1950 * 1
- 21 / 11 / 2120 * 500000
01 / 09 / 2021
- 21 / 09 / 2021
20 / 09 / 2021 * 3
***12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);