# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\-(\s*\d+\s*\/\s*\d+\s*\/\s*\d+)(\s*\*\s*\d+)?"
test_str = ("\n"
"I'm looking for regex to match date type patterns which start with hyphen and possible * + digit that might come after it. I have text input like this:\n\n"
"- 19/03/2081\n"
"- 20 / 02 / 1982\n"
"- 11/3/1950 * 1\n"
"- 21 / 11 / 2120 * 500000\n"
"01 / 09 / 2021\n"
"- 21 / 09 / 2021\n"
"20 / 09 / 2021 * 3\n"
"***12")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.