# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([א-ת]{1,3})([א-ת]+)?/$1/gm;t' <<< "דחוףףףףףףףףףף"