const regex = /([א-ת]{1,3})([א-ת]+)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([א-ת]{1,3})([א-ת]+)?', 'gm')
const str = `דחוףףףףףףףףףף`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);