using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([א-ת]{1,3})([א-ת]+)?";
string substitution = @"$1";
string input = @"דחוףףףףףףףףףף";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}