$re = '/([א-ת]{1,3})([א-ת]+)?/m';
$str = 'דחוףףףףףףףףףף';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;