using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z0-9]+(?:-[A-Za-z0-9]+)*";
string input = @"NXOS-ABCD-005-053 – Requirement No. 1
F56156-ISSU-1 - Requirement No 1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}