$re = '/^[A-Za-z0-9]+(?:-[A-Za-z0-9]+)*/m';
$str = 'NXOS-ABCD-005-053 – Requirement No. 1
F56156-ISSU-1 - Requirement No 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);