re = /^[A-Za-z0-9]+(?:-[A-Za-z0-9]+)*/m
str = 'NXOS-ABCD-005-053 – Requirement No. 1
F56156-ISSU-1 - Requirement No 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end