package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Za-z0-9]+(?:-[A-Za-z0-9]+)*`)
var str = `NXOS-ABCD-005-053 – Requirement No. 1
F56156-ISSU-1 - Requirement No 1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}