use strict;
my $str = 'NXOS-ABCD-005-053 – Requirement No. 1
F56156-ISSU-1 - Requirement No 1';
my $regex = qr/^[A-Za-z0-9]+(?:-[A-Za-z0-9]+)*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}