using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\b\w+(?:\s+\w+)*\b)(?:\s+\w+)*)\s+\2\b";
string substitution = @"$1";
string input = @"REGEXP_REPLACE([Product], ""(\b\w+\b)(?=\s+\b\1\b)"", "")
but it only removes the duplicate when they are right beside each other so the ""Blue Blue Car"" is fixed
to ""Blue Car"" but it doesn't fix ""Wild Yellow Wild Yellow Ball"" Because they are not right
beside each other
Wild Yellow Bouncy Ball Wild Yellow
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}