const regex = /((\b\w+(?:\s+\w+)*\b)(?:\s+\w+)*)\s+\2\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\b\\w+(?:\\s+\\w+)*\\b)(?:\\s+\\w+)*)\\s+\\2\\b', 'gm')
const str = `REGEXP_REPLACE([Product], "(\\b\\w+\\b)(?=\\s+\\b\\1\\b)", "")
but it only removes the duplicate when they are right beside each other so the "Blue Blue Car" is fixed
to "Blue Car" but it doesn't fix "Wild Yellow Wild Yellow Ball" Because they are not right
beside each other
Wild Yellow Bouncy Ball Wild Yellow
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);