import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((\\b\\w+(?:\\s+\\w+)*\\b)(?:\\s+\\w+)*)\\s+\\2\\b";
final String string = "REGEXP_REPLACE([Product], \"(\\b\\w+\\b)(?=\\s+\\b\\1\\b)\", \"\")\n\n"
+ "but it only removes the duplicate when they are right beside each other so the \"Blue Blue Car\" is fixed\n"
+ "to \"Blue Car\" but it doesn't fix \"Wild Yellow Wild Yellow Ball\" Because they are not right\n"
+ "beside each other\n"
+ "Wild Yellow Bouncy Ball Wild Yellow\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}