$re = '/((\b\w+(?:\s+\w+)*\b)(?:\s+\w+)*)\s+\2\b/m';
$str = 'REGEXP_REPLACE([Product], "(\\b\\w+\\b)(?=\\s+\\b\\1\\b)", "")
but it only removes the duplicate when they are right beside each other so the "Blue Blue Car" is fixed
to "Blue Car" but it doesn\'t fix "Wild Yellow Wild Yellow Ball" Because they are not right
beside each other
Wild Yellow Bouncy Ball Wild Yellow
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;