import Foundation
let pattern = #"((\b\w+(?:\s+\w+)*\b)(?:\s+\w+)*)\s+\2\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
REGEXP_REPLACE([Product], "(\b\w+\b)(?=\s+\b\1\b)", "")
but it only removes the duplicate when they are right beside each other so the "Blue Blue Car" is fixed
to "Blue Car" but it doesn't fix "Wild Yellow Wild Yellow Ball" Because they are not right
beside each other
Wild Yellow Bouncy Ball Wild Yellow
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)