#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^a-zA-Z](top)[^a-zA-Z]"
Local $sString = " top" & @CRLF & _
"" & @CRLF & _
" top-blue" & @CRLF & _
"" & @CRLF & _
" blue-top" & @CRLF & _
"" & @CRLF & _
" my top" & @CRLF & _
"" & @CRLF & _
" light-grn-top" & @CRLF & _
"" & @CRLF & _
" top-cotton" & @CRLF & _
"" & @CRLF & _
" laptop" & @CRLF & _
"" & @CRLF & _
" laptop-glossy" & @CRLF & _
"" & @CRLF & _
" green top 0192" & @CRLF & _
"" & @CRLF & _
" desktop 45WAI" & @CRLF & _
"" & @CRLF & _
" topbest" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")