// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^a-zA-Z](top)[^a-zA-Z]").unwrap();
let string = " top
top-blue
blue-top
my top
light-grn-top
top-cotton
laptop
laptop-glossy
green top 0192
desktop 45WAI
topbest
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}