re = /[^a-zA-Z](top)[^a-zA-Z]/
str = ' top
top-blue
blue-top
my top
light-grn-top
top-cotton
laptop
laptop-glossy
green top 0192
desktop 45WAI
topbest
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end