import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z](top)[^a-zA-Z]";
final String string = " top\n\n"
+ " top-blue\n\n"
+ " blue-top\n\n"
+ " my top\n\n"
+ " light-grn-top\n\n"
+ " top-cotton\n\n"
+ " laptop\n\n"
+ " laptop-glossy\n\n"
+ " green top 0192\n\n"
+ " desktop 45WAI\n\n"
+ " topbest\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}