$re = '/[^a-zA-Z](top)[^a-zA-Z]/';
$str = ' top
top-blue
blue-top
my top
light-grn-top
top-cotton
laptop
laptop-glossy
green top 0192
desktop 45WAI
topbest
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);