using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\*).+$|^.*[^\*]$|(?<=\*).+";
string input = @"*A
*A*
A*
*A*dffdg
kldf-sdf
sdfsdfdfg*
*dsfsdfgdsfg
fgdfgdfgdf*dfgdfg****************dfgdfg
fgdfgdfgdf*dfgdfg****************dfgdfg**
****
*
foo*barfoo
*aa
aaa
aa*
****
a**a
**a'
a***'
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}