import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\*).+$|^.*[^\\*]$|(?<=\\*).+";
final String string = "*A\n"
+ "*A*\n"
+ "A*\n"
+ "*A*dffdg\n"
+ "kldf-sdf\n"
+ "sdfsdfdfg*\n"
+ "*dsfsdfgdsfg\n"
+ "fgdfgdfgdf*dfgdfg****************dfgdfg\n"
+ "fgdfgdfgdf*dfgdfg****************dfgdfg**\n\n"
+ "****\n"
+ "*\n\n"
+ "foo*barfoo\n\n"
+ "*aa\n"
+ "aaa\n"
+ "aa*\n\n"
+ "****\n"
+ "a**a\n"
+ "**a'\n"
+ "a***'\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}