$re = '/^(?!\*).+$|^.*[^\*]$|(?<=\*).+/m';
$str = '*A
*A*
A*
*A*dffdg
kldf-sdf
sdfsdfdfg*
*dsfsdfgdsfg
fgdfgdfgdf*dfgdfg****************dfgdfg
fgdfgdfgdf*dfgdfg****************dfgdfg**
****
*
foo*barfoo
*aa
aaa
aa*
****
a**a
**a\'
a***\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);