re = /^(?!\*).+$|^.*[^\*]$|(?<=\*).+/m
str = '*A
*A*
A*
*A*dffdg
kldf-sdf
sdfsdfdfg*
*dsfsdfgdsfg
fgdfgdfgdf*dfgdfg****************dfgdfg
fgdfgdfgdf*dfgdfg****************dfgdfg**
****
*
foo*barfoo
*aa
aaa
aa*
****
a**a
**a\'
a***\'
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end