# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?!(?:and|not|or)\b)\w+/"$0"/gu;t' <<< "This and This not That"