import re
regex = re.compile(r"\b(?!(?:and|not|or)\b)\w+", flags=re.UNICODE)
test_str = "This and This not That"
subst = "\"$0\""
result = regex.sub(subst, test_str)
if result:
print(result)