const regex = /\b(?!(?:and|not|or)\b)\w+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?!(?:and|not|or)\\b)\\w+', 'gu')
const str = `This and This not That`;
const subst = `"$0"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);