use strict;
my $str = 'This and This not That';
my $regex = qr/\b(?!(?:and|not|or)\b)\w+/up;
my $subst = '"$0"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";