using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0+(?=[1-9])|\.0+$|(\.[0-9]*?)0+$";
string substitution = @"$1";
string input = @"120
--> 120
12
--> 12
120.00
--> 120
000329.0
--> 329
14.4200
--> 14.42
000430
--> 430
0.24000
--> 0.24
0.100
--> 0.1
1.0
--> 1";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}