import re
regex = re.compile(r"^0+(?=[1-9])|\.0+$|(\.[0-9]*?)0+$", flags=re.MULTILINE)
test_str = ("120\n"
"--> 120\n"
"12\n"
"--> 12\n"
"120.00\n"
"--> 120\n"
"000329.0\n"
"--> 329\n"
"14.4200\n"
"--> 14.42\n"
"000430\n"
"--> 430 \n"
"0.24000\n"
"--> 0.24\n"
"0.100\n"
"--> 0.1\n"
"1.0\n"
"--> 1")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)