$re = '/^0+(?=[1-9])|\.0+$|(\.[0-9]*?)0+$/m';
$str = '120
--> 120
12
--> 12
120.00
--> 120
000329.0
--> 329
14.4200
--> 14.42
000430
--> 430
0.24000
--> 0.24
0.100
--> 0.1
1.0
--> 1';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;