const regex = /^0+(?=[1-9])|\.0+$|(\.[0-9]*?)0+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^0+(?=[1-9])|\\.0+$|(\\.[0-9]*?)0+$', 'gm')
const str = `120
--> 120
12
--> 12
120.00
--> 120
000329.0
--> 329
14.4200
--> 14.42
000430
--> 430
0.24000
--> 0.24
0.100
--> 0.1
1.0
--> 1`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);