import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^0+(?=[1-9])|\\.0+$|(\\.[0-9]*?)0+$";
final String string = "120\n"
+ "--> 120\n"
+ "12\n"
+ "--> 12\n"
+ "120.00\n"
+ "--> 120\n"
+ "000329.0\n"
+ "--> 329\n"
+ "14.4200\n"
+ "--> 14.42\n"
+ "000430\n"
+ "--> 430 \n"
+ "0.24000\n"
+ "--> 0.24\n"
+ "0.100\n"
+ "--> 0.1\n"
+ "1.0\n"
+ "--> 1";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}