#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=_)[^._]*(?=\.)"
Local $sString = "India_AP_Dev1.txt" & @CRLF & _
"USA_GA_QA2.txt" & @CRLF & _
"USA_NY_AWSDev1.txt" & @CRLF & _
"AUS_AA_BB_QA4.txt"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")