import re
regex = re.compile(r"(?<=_)[^._]*(?=\.)")
test_str = ("India_AP_Dev1.txt\n"
"USA_GA_QA2.txt\n"
"USA_NY_AWSDev1.txt\n"
"AUS_AA_BB_QA4.txt")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")