import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=_)[^._]*(?=\\.)";
final String string = "India_AP_Dev1.txt\n"
+ "USA_GA_QA2.txt\n"
+ "USA_NY_AWSDev1.txt\n"
+ "AUS_AA_BB_QA4.txt";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}