re = /(?<=_)[^._]*(?=\.)/
str = 'India_AP_Dev1.txt
USA_GA_QA2.txt
USA_NY_AWSDev1.txt
AUS_AA_BB_QA4.txt'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end